Poker not working on my iPhone

I’ve been having problems trying to play some mtt’s. Nothing is happening when I click to play poker:


What can i do to fix it?

I used to have that happen too when using safari and it looks like you are using that as well. Ignition asked me to use Chrome instead as its more compatible apparently and aside from a couple technical issues from their side recently its worked pretty well:


We’ve confirmed with @moneykey that using Chrome worked, thank you @Thatworks!

1 Like

I’m having the same issue on my iPhone. I’ve tried safari, chrome and other browsers but none work for me.

Welcome to the forum :slight_smile:

Is your device currently running the latest version of iOS?

Yes my iPhone is updated to latest version of iOS

IOS 13.2 is the latest.

That’s good to know.

Just to confirm, are you encountering a black screen on all the different browsers you’ve tried?

If you’re encountering this on Google Chrome, it might be worth clearing your browser’s saved cache. The steps outlined here will help guide you on how to do so, but the steps may vary depending on the version you have installed.

Please reach out via PM if you’re still experiencing issues.

Thanks :+1:
Just cleared Safari browser cache and everything seems to be working well.



We’re glad to hear it. Let us know if you encounter any other problems.