Register/Take Seat not visible

Im so sick right now. Have 5 deep tourneys, close client and cant get back on my tables. So pissed!!!

WTF do I do??!!!

Try the browser?

Browser and phone dont work

try this guide I made to FULLY uninstall and reinstall Ignition Casino Poker on Windows 10.

  • Go to Windows Settings > Apps > Apps & Features > Choose the app of the site you want to uninstall: “Ignition Casino Poker” then click Uninstall and follow the prompts to uninstall.

  • Open File Explorer in Windows and go to C: > Program Files (x86) > select and delete folder: “Ignition Casino Poker”.

  • In File Explorer go to C: > Users > (Your Windows User Name) > select and delete the folder: “Ignition Casino Poker”.

  • In File Explorer click on “View” at the top, then on the top right side select the box for “Hidden Items”. This will allow you to access the AppData folder which holds cached files that need to be deleted to fully uninstall past versions of the poker software. Access the AppData folder in the next step.

  • In File Explorer go to C: > Users > (Your Windows User Name) > AppData > Roaming > select and delete folders: “Ignition Casino” and “ignitioncasino-eu-poker”.

  • (This step may or may not be needed, but it won’t hurt) Clear Google Chrome browsing data. To do so click the 3 vertical dots in the top right of the browser then click Settings, scroll to the bottom and click on Advanced, under the section Privacy and Security click on Clear Browsing Data, click Basic, select Time Range: All, select “Cookies and other site data” also select “Cached images and files”, click Clear data. Close browser.

  • Make sure Windows is updated. To do so open Windows Settings > Update & Security > Windows Update > click on Check for updates.

  • Restart the computer.

  • Go to and download a fresh copy of the software and install it, but make sure no third party poker software is running when installing the poker site software. Examples of third party poker software are Card Catchers, HEM, PT4, DriveHUD, Table Tamer etc.


I dont use other programs. I am not sure if this did the trick, but I turned off my WIFI on my phone and used cellular data and got on 3 of my 5 tables remaining. Eventually died. FML. Shouldv’e learned from my past mistakes when the client is kind of acting up, DO NOT close client and open again. Just ride it out or I might get locked out. Paid the price for making that mistake on a big day like this.

this same exact thing happened to me 9 days ago

Thanks for reporting this @LennoxWay - It’s something that we’re aware of and are currently investigating it. I’ve gone ahead and moved your report over to it’s own topic so that we can track this issue.

I’m going to take a look at the tournaments you were in, but in the meantime could you confirm what operating system you’re using?

Nice and very detailed with my Windows 10. Last time I would uninstall ignition, search for anything named ignition then delete it. After I re-download and open Ignition, my email and password would still be saved! I couldn’t do all of this last night when I was in panic mode. This is probably what I needed to begin my run-good from now on. Thanks.

1 Like

Has anyone else been locked out of a tournament that you registered for like this? When I press the blank button, nothing happens.

same for me

This is still an issue our team are working on resolving. If it’s happened to anyone else, please let us know and be sure to include a screenshot of the issue.

Hi, I ran into a weird issue last night. I went to re-entry the 8:08pm EST Crazy’s Eights and it never sent me to my new table. When I went into the tournament lobby, the “Seat Me” button was there, but it was missing the words “Seat Me” and didn’t sent me to my new table/seat when I clicked on it. I tried rebooting and same issue, it never worked. I ended up never playing a hand on my 2nd bullet and being blinded out.

I also never saw my name list in the player list. I notice another issue there, it only listed the top 1k players when there was still 1.2k remaining. I was trying to find my ID to open up my new table/seat manually , but to no avail as there was too many tables.

Can you guys look into this glitches and help me with a refund? I e-mail Ignition support about it, just waiting to hear back. Thanks

Hey @Billy723, I’m sorry to hear you experienced this. Do you happen to have a screenshot of when it happened? Our team is still working on resolving this but I’m going to take a look at your tournament and send you a PM shortly.

I was disconnected from the client on Sunday when I logged back in the take my seat button was missing from the lobby as you can see in the screen shot. Live chat has been zero help with this issue telling me to unplug my modem when it had nothing to do with my internet connection. Are there any moderators in this forum that can help with this issue.

@JDL84_123, Welcome to the Forum.

We’ve moved your post here as it does seem to relate to this topic. Read above and let us know if you’re able to find anything that helps. Also, some basic troubleshooting steps are provided here and here (Even if you’re not using a Mac)

If after following these steps you’re still not able to see the ‘Take My Seat’ let us know below.

I’m not using a Mac and I tried all the basic trouble shooting steps. This seems to happen in big field tournaments when the servers are overloaded. Players should be refunded a tournament ticket at the very least when this happens. Not told by live chat to unplug my modem when it had nothing to do with my internet connection

I stated that these steps would work whether or not you have a Mac as the player in one thread was using a Mac but they work for most PC’s. We see that you haven’t yet clicked on the links, and there are quite a bit of troubleshooting tips to try out between both posts that might help. We understand if you feel that this wasn’t caused by your your Internet, but resetting your Internet Connection does fix certain issues and there are many more steps in the links provided.

However, if the main issue is to look into a tournament you were disconnected from, was this the tournament provided in the screenshot?

Yes. I had other games rinning on ignition and other tables running from other sites too, so I know it had nothing to do with my connection.