Tournament Lobbies won't load or won't let you register

I am trying to load a MTT lobby to register in it and this is as far as it will load :frowning_face:

This is what I have been running into also while trying to register for tournaments. I click the register button then the cursor shows the hourglass symbol like it is about to load the tournament. A little time passes then my regular cursor comes back and I haven’t been registered for the tournament.



I’m a big time regular for 3+ years and never seen this issue. I tried restarting my computer and then uninstalling and reinstalling software. Neither worked.

From the screenshot - I am registered in this sit n go but it is not letting me “Take Your Seat”. I recently downloaded some other software on my computer, maybe its messing with it?? What is the cause of this? What is the solution?

Do you see (me) after a registered player? I do not on your screenshot. Otherwise, you could click on your player id, and take seat that way.

2 posts were merged into an existing topic: Down for essential maintenance